Contourner l'erreur d'Eclipse à l'instal Jetty Launcher

2006-03-17

Jetty Launcher est un plugin qui permet de piloter Jetty depuis Eclipse. La version 1.3.0 de Jetty Launcher ne fonctionne pas directement avec Eclipse version 3.1.0 : en suivant la procédure pour l’utiliser, le message d’erreur suivant apparait dans l’Error Log (via menu Window / Show View) :
Problems occurred when invoking code from plug-in: “org.eclipse.jface”.

Pour y remédier, il faut déjarer le plugin dans le dossier Eclipse idoine. Par exemple :

cd /usr/lib/eclipse/plugins 
mkdir com.iw.plugins.jettyLauncher\_1.3.0 
cd com.iw.plugins.jettyLauncher\_1.3.0 
unzip ../com.iw.plugins.jettyLauncher_1.3.0.jar

Une fois fait, supprimer le jar

rm ../com.iw.plugins.jettyLauncher_1.3.0.jar

Relancer Eclipse et suiver les instructions d’utilisation de jettyLauncher.